Symitar Maintenance
Incident Report for UFirst FCU
Resolved
Maintenance has completed.
Posted Jan 14, 2025 - 07:51 MST
Investigating
Starting 1/14/2025 @ 7 AM we will be undergoing some Symitar Maintenance for our Internal system access. Anything that connects externally will not lose connection. Maintenance should last an hour or less.
Posted Jan 14, 2025 - 06:56 MST
This incident affected: Symitar.