Card Wizard Emergency Maintenance
Incident Report for UFirst FCU
Resolved
This incident has been resolved.
Posted Jan 15, 2025 - 13:17 MST
Investigating
Card Wizard has informed us they are doing Emergency Maintenance on their systems. There may be some issues during this maintenance.
Posted Jan 15, 2025 - 12:10 MST
This incident affected: Card System.