MeridianLink Chexsystems Down
Incident Report for UFirst FCU
Resolved
This incident has been resolved. Please contact IT Help Desk if you are still experiencing issues.
Posted Jan 21, 2025 - 10:44 MST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 17, 2025 - 10:21 MST
Update
We are continuing to investigate this issue.
Posted Jan 17, 2025 - 10:20 MST
Update
We are continuing to investigate this issue.
Posted Jan 15, 2025 - 16:56 MST
Investigating
We are currently investigating this issue.
Posted Jan 15, 2025 - 16:50 MST
This incident affected: Employee Banking Systems.